Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Please Help Me.. ADO

DroopyADroopyA Member Posts: 175
Ive made a really small application using vb6(sp5). I have a microsoft Access 2000 database and use and ADODB connection to read and write to my database. Everything works fine on the codeing machine. But when I make an install it says "Provider not found"

I know nothing about making install files (thats what I'm trying to learn now) so can any of you help me. I think the install might be fine but I set the Database path to the following:

g_strDBLocation = "Provider=Microsoft.Jet.OLEDB.3.51;Data Source=" & App.Path & "DataMainDatabase.mdb"

Should I not hardcode the Provider? How do I know what Providers are available? What could I be missing in my install?

Thank you
-N473

Comments

  • leeosleeos Member Posts: 1,212
    : Ive made a really small application using vb6(sp5). I have a microsoft Access 2000 database and use and ADODB connection to read and write to my database. Everything works fine on the codeing machine. But when I make an install it says "Provider not found"
    :
    : I know nothing about making install files (thats what I'm trying to learn now) so can any of you help me. I think the install might be fine but I set the Database path to the following:
    :
    : g_strDBLocation = "Provider=Microsoft.Jet.OLEDB.3.51;Data Source=" & App.Path & "DataMainDatabase.mdb"
    :
    : Should I not hardcode the Provider? How do I know what Providers are available? What could I be missing in my install?
    :
    : Thank you
    : -N473
    :

    you dont need that connection strign thing anyway. anyway that looks like DAO connection string to me.. ( could be wrong )

    [code]
    cn.ConnectionString = "DSN=XXXX;UID=XXXX;PWD=XXXX;"
    [/code]

    thats it.


  • lionblionb Member Posts: 1,688 ✭✭
    [b][red]This message was edited by lionb at 2002-10-29 10:42:7[/red][/b][hr]
    : : Ive made a really small application using vb6(sp5). I have a microsoft Access 2000 database and use and ADODB connection to read and write to my database. Everything works fine on the codeing machine. But when I make an install it says "Provider not found"
    : :
    : : I know nothing about making install files (thats what I'm trying to learn now) so can any of you help me. I think the install might be fine but I set the Database path to the following:
    : :
    : : g_strDBLocation = "Provider=Microsoft.Jet.OLEDB.3.51;Data Source=" & App.Path & "DataMainDatabase.mdb"
    [blue]Change provider to
    Provider=Microsoft.Jet.OLEDB.4.0 [/blue]


    : :
    : : Should I not hardcode the Provider? How do I know what Providers are available? What could I be missing in my install?
    : :
    : : Thank you
    : : -N473
    : :
    :
    : you dont need that connection strign thing anyway. anyway that looks like DAO connection string to me.. ( could be wrong )
    :
    : [code]
    : cn.ConnectionString = "DSN=XXXX;UID=XXXX;PWD=XXXX;"
    : [/code]
    :
    : thats it.
    :
    :
    :



  • Chris BrownChris Brown USAMember Posts: 4,624 ✭✭

    _____ | http://forcoder.org | free ebooks and video tutorials about || PHP, Visual Basic, Objective-C, Java, Swift, C#, PL/SQL, R, Perl, JavaScript, Visual Basic .NET, Delphi, Python, Go, Ruby, C++, Assembly, MATLAB, C, Scratch Ada, Hack, Bash, Apex, COBOL, D, LabVIEW, Lua, SAS, Logo, Alice, Rust, VBScript, Scala, Fortran, ML, FoxPro, Prolog, Julia, Lisp, Dart, ABAP, Transact-SQL, F#, Kotlin, Clojure, Crystal, Awk, Erlang, Scheme || ________

Sign In or Register to comment.