Run a JAR file from path containing multi-byte chars

I'm unable to execute a JAR file if that file resides within a path which contains multi-byte characters. Here is an example:

The JAR file:

F:DEMO-CFM56-?i2?3i??3????3iiiXClick to Generate Report.jar

The exception:

Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/jdt/internal/jarinjarloader/JarRsrcLoader
Caused by: java.lang.ClassNotFoundException: org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader
at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
Could not find the main class: org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader. Program will exit.

I've tried building this JAR with eclipse, netbeans and manually.

I've tried no space in the name.

I've tried to run from the command-line:

java -jar "Click To Generate Report.jar"

java -cp
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!