I have a frame system page. I desire to load an array found in say FRAMEA into FRAMEB. The problem is that I name them generically based on how many Database records are returned.
The problem lies in the array naming scheme "a0, a1, .... an". I tried this:
var arrayName; [green]//name of array to be fetch in other frame [/green]
var total = parent.parent.hidden.counter; [green]//total arrays created, fetched from other frame [/green]
var index = 0; [green] //array indexer [/green]
while (index < total)
arrayName = "a" + index; [green]//name scheme as above, a0, a1.... [/green]
document.write(arrayName); [green] // this prints out correctly, say for index = 0, output is "a0" [/green]
index = index + 1;
var Message = parent.parent.hidden.arrayName; [green] // HERE IS THE PROBLEM, the variable should be called: a0, a1, ..., an
// I am instead placing a variable's NAME instead!![/green]
Please, can anybody help me ASAP. This is bugging me. If anything, give me alternative methods.