Problems installing BP

Hi

I recently found some older sourcecodes that I wrote back in the good old DOS-days - I even found my Borland Pascal and tried to install it but I keep getting this error: Too many subdirectories and the installation breaks. I've tried this under XP (ok, XP isn't really nice to DOS programs) so then I tried an installation under MS-DOS (using Virtual PC by Connectix) and I get the same thing. Any ideas what's causing this and how it can be fixed ?
This is what I tried under Virtual PC: I found a backup of my BP-Directory and simply copied it to the virtual hd - I then added c:pin to the path so I could just start it
I then found a backup of my BP-Directory and added bpin to the path. I can start the IDE just fine under Virtual PC - but as soon as I try to compile something I get "Internal Error 216 at [address:here]" and that's it. Does anyone know a way how I can run BP in a nice 'sandbox' environment like Virtual PC or VMWare ?

Thanks for your help

NoNeX

Comments

  • [b][red]This message was edited by Moderator at 2003-3-20 7:45:35[/red][/b][hr]
    : I recently found some older sourcecodes that I wrote back in the good old DOS-days - I even found my Borland Pascal and tried to install it but I keep getting this error: Too many subdirectories and the installation breaks. I've tried this under XP (ok, XP isn't really nice to DOS programs) so then I tried an installation under MS-DOS (using Virtual PC by Connectix) and I get the same thing. Any ideas what's causing this and how it can be fixed ?
    : This is what I tried under Virtual PC: I found a backup of my BP-Directory and simply copied it to the virtual hd - I then added c:pin to the path so I could just start it
    : I then found a backup of my BP-Directory and added bpin to the path. I can start the IDE just fine under Virtual PC - but as soon as I try to compile something I get "Internal Error 216 at [address:here]" and that's it. Does anyone know a way how I can run BP in a nice 'sandbox' environment like Virtual PC or VMWare ?


    It works just fine under XP here. Try checking the compiler settings to make sure the directories are set right, or what I would personally do is reinstall from the disks instead of using a backup.

    Nevermind I see you said you tried installing and got that error message. Maybe the directory you are installing to is too long? Are you just trying C:BP? Also, if you are installing from the hard-drive instead of disks, maybe the source directory is too long? I'd try copying the install to C:BPINST and installing from there to C:BP. If you still get that error I dont know what else it could be.
  • Hi

    Yes, I was trying to install to C:BP - but the installation source was on E:CodeBP - after moving to C:BPinst it installed just fine - I thought it had something to do with the destination directories and didn't think about the source directoy.
    Right now I'm moving all the files to a directory on C: in Virtual PC and will see what'll happen... so... installing... it installs just fine - doh =)
    So now I'm down to the "Internal Error 216 at 0003:7595." - no idea what's triggering this.
    I can compile using Turbo Pascal - the only drawback now: Virtual PC dies after leaving the TP-IDE. Not really what I wanted ;-)
    In case anyone is using BP under Virtual PC or VMWare - please let me know.

    NoNeX

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories