Compact Framework?!

[b]Error 1 Projects targeting .NET Compact Framework 1.0 require version 1.1 of the .NET Framework, which is not detected on this machine.[/b]

I installed the Compact Framework 3.0 which is supposed to be backward-compatible. I restarted my computer and still I get the preceding Error message when I go to test my application.
Any ideas how I can remedy this problem? I really want to begin making programs for smartphones, PDA's and the Blackberry.

Thanks for your help!


  • what .NET frameworks do you have installed on your machine?
  • I have .Net Framework 2.0
  • have you tried changing the target framework of your project?
    Right-click on your project in the solution explorer and go to properties. One of the properties will be the "Target Framework".
    you may need to set this to something you have installed on your machine.

    Seems odd to me that having 3.0 doesn't include 1.0
  • I see only the option to change "Change Target Platform..."
  • Ya - I'm not familiar with the project type you have there. Can you maybe port the code over into a new project created after the 3.0 update?
  • Project type is Smartphone 2003, using template: Device Application(1.0)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!