Namespace Problems

I'm making an addIn to Autodesk Inventor 11 using Visual Studio.Net 2003 (VB.Net).
My VB.Net doesn't know namespace of Inventor. All Inventor words have error underline.

--------------------------------------------------------------
Imports [u]Inventor[/u]
Imports System.Drawing
Imports System.Windows.Forms
Imports System.Runtime.InteropServices

Namespace SimpleAddIn
_
Public Class StandardAddInServer
Implements [u]Inventor.[/u]ApplicationAddInServer

--------------------------------------------------------
I have installed Inventor Wizard, but it doesn't solve the problem.
That code is Inventor API AddIn sample.What can I do?

Comments

  • seancampbellseancampbell Pennsylvania, USA
    You have to add the .Dll package containing Inventor to your references.

    In the solution explorer, right click the References folder item and click "add reference". There should be a way to search for an external library, find your package and include it.

    -sean
  • I have installed an Inventor AddIn baggage to Visual Studio before.

    Now, after your advice, I added about four library references extra (that included "Inventor"). It wors well. There are not zigzag-underlines with Inventor-words and its properties.

    Many thanks!

    PS. I have gotten to know, it is not a piece of cake to make program solutions when being a Machine Constructor.

    - Late
  • seancampbellseancampbell Pennsylvania, USA
    Glad that I could help
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories